WordPress Related Postsを3.6.4 へ更新したらエラーが出て画面真っ白

関連記事を表示してくれるプラグイン「WordPress Related Posts」を 3.6.3 から 3.6.4 へ更新したところ以下のエラーが表示されました。

Parse error: syntax error, unexpected ‘[‘, expecting ‘)’ in /path/to/wp-content/plugins/wordpress-23-related-posts-plugin/config.php on line 130

プラグインのアップデートでエラーになるのは初めて。

動作環境

  • WordPress:バージョン 4.7.5
  • テーマ:XeoryBase バージョン 0.1.8

対処方法

FTPでサーバーに潜って「WordPress Related Posts」のディレクトリを削除。
とりあえず元のように表示されました。

このエラーが対応されたバージョンがリリースされるまでは、このプラグインの使用はお預け。

vagrant up時のNFSのマウントに失敗した場合の対処方法

起きてVagrantちゃん!開発の時間だよ!

日本語でおk。

続きを読む

Bitbucketにプッシュすると「access via a deployment key is read-only.」SSHまわりでエラー

こいつに何度も阻まれた・・・。

Bitbucketへプッシュしようとすると以下のエラーが表示された。

続きを読む

PostgreSQLの結果表示を見やすくする方法

PostgreSQLの結果表示ってすごい見づらい。カラムが多いとカオスになって何がなんだか分からない。クライアントソフトを使えば済むことですが、PostgreSQLの良いクライアントソフトは有料のものがほとんど。でも奥さん、コマンド一つでそれを解消する方法があるんです。それがこちら。

続きを読む

Vagrantで複数の環境を構築したいならVagrantfileは複数で運用した方が良さそう

普段の開発はVagrant環境上でやっているのですが、その場合、複数の環境で行わなければならない時がありますよね。例えば、会社と個人プロダクトの環境が違っていたりとか。
1つの環境内でやってもよいのですが、設定が面倒だったり、気持ち的になんか嫌だったり(会社のとは分けたいし)。

Bundlerやrbenvを弄ったり、VagrantのVagrantfileを弄ったりと色々試してみて(ホストとのネットワークエラーやntsまわりで詰まる詰まる)、この方法に落ち着きました。

続きを読む