関連記事を表示してくれるプラグイン「WordPress Related Posts」を 3.6.3 から 3.6.4 へ更新したところ以下のエラーが表示されました。

Parse error: syntax error, unexpected ‘[‘, expecting ‘)’ in /path/to/wp-content/plugins/wordpress-23-related-posts-plugin/config.php on line 130

プラグインのアップデートでエラーになるのは初めて。

動作環境

  • WordPress:バージョン 4.7.5
  • テーマ:XeoryBase バージョン 0.1.8

対処方法

FTPでサーバーに潜って「WordPress Related Posts」のディレクトリを削除。
とりあえず元のように表示されました。

このエラーが対応されたバージョンがリリースされるまでは、このプラグインの使用はお預け。